Tab Characters Don't Format Correctly

Suggestions, feature requests and bug reports.
Posts: 3
Joined: Tue May 23, 2017 7:43 pm

Tab Characters Don't Format Correctly

PostPosted by traughber » Tue May 23, 2017 8:19 pm

When I try to use the following as a Text Expander replacement
Code: Select all
SELECT
   Field1
   ,Field2
   ,Field3
FROM Table
WHERE 1=1


I get the following:

Code: Select all
SELECT
   Field1
      ,Field2
         ,Field3
         FROM Table
         WHERE 1=1   


So it's not handling the tabs correctly. I also tried using spaces in the replacement instead of tabs and I get the same result.

Posts: 3
Joined: Tue May 23, 2017 7:43 pm

Re: Tab Characters Don't Format Correctly

PostPosted by traughber » Tue May 23, 2017 8:20 pm

I also tried using {Tab} as well. Same result.

Site Admin
User avatar
Posts: 628
Joined: Sat Mar 02, 2013 9:02 pm

Re: Tab Characters Don't Format Correctly

PostPosted by Marko » Tue May 23, 2017 10:53 pm

This depends on you editor settings. FastKeys sends text exactly as you would type it. If your editor is set to use auto indents, the result can be different. To avoid this you may send text using clipboard - set option Text Expander/Advanced/Use clipboard if text length exceeds... to lower value (1).

Posts: 3
Joined: Tue May 23, 2017 7:43 pm

Re: Tab Characters Don't Format Correctly

PostPosted by traughber » Tue May 23, 2017 11:07 pm

Ok. Thanks.

Return to Suggestions

Who is online

Users browsing this forum: No registered users and 1 guest